bjellings

Noen som er flinke i Numbers/Excel?

Hei

Jeg er ganske noob i Numers/excel. Jeg har laget meg et regneark for utregning av noe avgift greier(trenger ikke gå mer inn på det nå)

Problemet mitt er som følger:

Si at jeg f.eks skal regne ut avgiften på noe som veier 700kg.

Avgiften vil være 10kr pr.kg opp til 150kg, 20kr pr. kg opp til 300 kg, 30kr pr.kg opp til 400kg og 35kr pr.kg på alt over 500kg.

Det jeg ønsker er å bare fylle ut vekten i en rute og få programmet til å regne ut avgiften i kroner.

Jeg kan sette det opp slik: (men jeg ønsker å forenkle det)

0-150kg 150x10=1500

151-300kg 150x20=3000

301-400kg 100x30=3000

401-500kg 300x35=10500

Sum: 18000kr

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Kan noe slikt funke?

forumlas.png

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Antar du mener 35 kr på alt over 400 kg. Foreslår følgende formel i celle A2:

=HVIS(A1<151;A1*10;HVIS(A1<301;150*10+(A1-150)*20;HVIS(A1<401;150*10+150*20+(A1-300)*30;150*10+150*20+100*30+(A1-400)*35)))

Skriv så antall kilo inn i celle A1.

post-533-0-10568400-1327263995_thumb.jpg

Endret av Kopmaniac
0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Hei

Jeg er ganske noob i Numers/excel. Jeg har laget meg et regneark for utregning av noe avgift greier(trenger ikke gå mer inn på det nå)

Problemet mitt er som følger:

Si at jeg f.eks skal regne ut avgiften på noe som veier 700kg.

Avgiften vil være 10kr pr.kg opp til 150kg, 20kr pr. kg opp til 300 kg, 30kr pr.kg opp til 400kg og 35kr pr.kg på alt over 500kg.

Det jeg ønsker er å bare fylle ut vekten i en rute og få programmet til å regne ut avgiften i kroner.

Jeg kan sette det opp slik: (men jeg ønsker å forenkle det)

0-150kg 150x10=1500

151-300kg 150x20=3000

301-400kg 100x30=3000

401-500kg 300x35=10500

Sum: 18000kr

Denne funker i Excel iallefall

Gitt at du har tallet i celle E18

=MIN(150;E18)*10 + MIN(MAX(0;E18-150);150)*20 + MIN(MAX(0;E18-300);100)*30 + MAX(0;E18-400)*35

Logikken her er da at første del er det minste av tallet selv og 150 ganger 10, andre del er først det høyeste av 0 og tallet - 150 (i fall det er under 150 kg), så minimum av det tallet og 150, osv

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Gitt at du setter kilo tallet i celle A1, vil denne formelen fungere i valgfri celle:


=HVIS(A1<=150;A1*10;

HVIS(A1<=300;1500+(A1-150)*20;

HVIS(A1<=400;4500+(A1-300)*30;

HVIS(A1>400;7500+(A1-400)*35

))))

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Takk for kjappe svar, men jeg sliter alikevel med å skrive om formelen til å passe til mine tall.

Jeg prøvde å legge inn avgiftstall for vekt på import

0-1150kg - 36,89pr kg

1151-1400kg - 80,41 pr kg

1401-1500kg - 160,84 pr kg

over 1500kg - 187,84 pr kg

Denne formelen endte jeg opp med:

=HVIS(C4<1151;C4*36,89;HVIS(C4<1401;1150*36,89+(C4-1150)*80,41;HVIS(C4<1501;1150*36,89+1150*80,41+(C4-1400)*160,84;1150*36,89+1150*80,41+100*160,84+(C4-1500)*187,84)))

Sett att tyngden er 1525kg skal total vektavgift komme på 83 286,50kr

Svaret i mitt regneark blir: 155675kr

Hva gjør jeg feil???

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Jeg fikk det til allikevel:) Tusen takk for hjelp.

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

PS. hadde du brukt mitt regneark hadde du sluppet å endre formlene etter dine tall, bare å endre grenseverdiene og pris pr intervall i kolonne A og B ;)

Også enklere neste gang avgiftene endres.

Flott at du fikk det til å fungere, men synd at du gikk for den programmeringsteknisk minst elegante løsningen, hehe ;)

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Opprett en konto eller logg inn for å kommentere

Du må være medlem for å kunne skrive en kommentar

Opprett konto

Det er enkelt å melde seg inn for å starte en ny konto!


Start en konto

Logg inn

Har du allerede en konto? Logg inn her.


Logg inn nå

  • Hvem er aktive   0 medlemmer

    Ingen innloggede medlemmer aktive